Unable to access portal
Incident Report for ABB Powertrain
Resolved
Between 09:30 PM and 11:05 PM UTC on 19 November 2024, Our portals experienced technical issues and users were not able to access portals. No data has been lost. This issue is now resolved
Posted Nov 19, 2024 - 23:31 UTC
Investigating
Dear user, starting 9.30 PM on 19th November 2024 UTC, Our portal is experiencing technical issues and users cannot access portal. No data has been lost. We are working on bringing the system back online as quickly as possible.
We apologise for any inconvenience caused and thank you for your understanding.
Your ABB Powertrain Team.
Posted Nov 19, 2024 - 21:57 UTC
This incident affected: Portal.