Dear user, Between 03:00 PM UTC on 12 September 2025 and 08:00 AM UTC on 17 October 2025, our Mobile App data visualization was delayed. Data collection was not impacted. No data has been lost. This issue is now resolved.
Your ABB Powertrain Team.
Posted Oct 17, 2025 - 08:17 UTC
Update
Dear user, Mobile App data visualization is still delayed. We are performing updates on our backend system to avoid potential issues. Please continue to use the portal for visualization. We will let you know as soon as further updates are available.
Posted Sep 18, 2025 - 12:07 UTC
Update
Dear user, We are still reviewing the outcome of the fix that was implemented.
Posted Sep 17, 2025 - 13:34 UTC
Identified
Dear user, The issue has been identified and a fix has been implemented. We are currently evaluating the results.
Posted Sep 16, 2025 - 13:41 UTC
Update
Dear user, We are still investigating the issue and continuing to work on bringing the system back to normal operation.
Posted Sep 16, 2025 - 12:27 UTC
Investigating
Dear user, starting 03:00 PM on 12 September 2025 UTC, our Mobile App data visualization is delayed. Data collection is not impacted. Please continue to use the portal for visualization. We are working on bringing the system back to normal performance as quickly as possible.
We apologize for any inconvenience caused and thank you for your understanding. Your ABB Powertrain Team.