Digital Powertrain Mobile Application Version update

Incident Report for ABB Powertrain

Resolved

Dear Powertrain Mobile App Users,

Please be informed that the update for Digital Powertrain Mobile Application Version 8.20 was successfully deployed on 18/03/25.

Your ABB Powertrain Team
Posted Mar 19, 2025 - 06:36 UTC

Monitoring

Dear Powertrain Mobile App Users,

Please be informed that a fix for Digital Powertrain Mobile Application Version 8.20 has been deployed on 18/03/25. This update addresses a critical bug that may impact the functionality of previous versions of the application 8.19.

Required Action: Users currently operating an older version of the mobile application are requested to upgrade to latest Version 8.20. It is imperative that this update is completed to ensure uninterrupted access to our services.

We appreciate your immediate attention to this matter and thank you for your continued Support.

Sincerely,
Your ABB Powertrain Team
Posted Mar 18, 2025 - 05:00 UTC
This incident affected: Mobile App.